Version 8.20.00

 

 

 

Release Note

 

Contents
  1. 1        Introduction. 3
  2. 2        Data Reorganisation. 4
  3. 3        Multiple Catalogue Code Import Functionality. 4

3.1         Importing Catalogue Codes. 5

3.2         Purchase Orders. 5

  1. 4        BACS Functionality. 8

4.1         Switching on BACS. 8

4.2         Setup Options. 10

4.3         BACS Transaction Entry. 18

4.4         BACS Reports. 27

4.5         Report Maintenance Log. 30

  1. 5        Other Functionality. 31

5.1         Purchase Orders. 31

5.2         Records – Drill down on Income Sources/Suppliers. 31

5.3         Records – Search on Income Sources/Suppliers. 31

  1. 6        PR Tracker Items. 33

6.1         Supplier Record. 33

6.2         Printed BACS Remittance. 33

6.3         Value Box on Purchase Orders. 33

  1. 7        Installing RM Finance on Microsoft Windows 7 Computer. 34
  2. 8        Crystal reports. 35

 


1      Introduction

 

These release notes detail enhancements included in RM Finance v8.20, a number of PR Tracker items have also been corrected.

 

RM Finance incorporates a Catalogue Import routine, allowing schools to import Catalogue Codes from specific suppliers. This functionality has been enhanced to include Multiple Catalogue Imports as well as enhancements to the existing functionality.

 

To augment the BACS functionality already available within RM Finance two additional BACS exports have been added to this release, they are Yorkshire Bank and the Co-operative Bank.

(Please contact your Account Manager for details if your BACS functionality is supplied through another provider)

 

A number of items from the RM Finance ‘Wish List’ have also been included in this release:

 

  • Within Purchase Ordering a warning now      appears if the bank will be overdrawn when posting an invoice.
  • The drill down from Records - Income      Sources/Suppliers on both Turnover Year to Date and Turnover Period to      Date shows the invoice number
  • In Income Sources & Suppliers It is      possible to search on Postcode
        
        

 

The PR Tracker items corrected include:

           

  • It is no longer possible to create a      Supplier with no name via Purchase Ordering
  • The printed BACS Remittance has been      adjusted to fit a window envelope
  • The Total Value boxes on the Purchase      Orders, Amend Process screen no longer truncate the value

 

For details of changes prior to v8.20 please refer to Release Notes from previous releases.

 

.

 

 


 

2      Data Reorganisation

 

When a data file from a previous version of RM Finance is first opened by RM Finance v8.20.00, it will require reorganisation. This process is triggered automatically when the user first logs into the data file. This may take several hours if you have been importing Catalogue Codes over a number of years. It is recommended that you take a backup prior to upgrade. If you would like to clear out the existing catalogue codes prior to running the upgrade RM offer a chargeable service (please contact the Support HelpDesk)

 

Once a data file has been reorganised, it must not be used with a previous version of RM Finance or Cash Accounts. It is therefore important to upgrade all RM Finance installations that are connected to a data file at the same time.

 

Prior to upgrading to RM Finance v8.20, you should ensure you have a good backup of your data file.

 

If you have any queries regarding any of the new functionality described in this document, please do not hesitate to contact our support department.

 

3      Multiple Catalogue Code Import Functionality[tks1]

 

 

Although there are no changes to the screen layout of the Suppliers Catalogue code screen, development has taken place behnd the scenes to allow ‘duplicate’ codes. These duplicate codes can only exist if they are attached to different suppliers. The new development attaches the supplier code to the catalogue code making it unique. That is why when importing the catalogue codes (below) the supplier must exist in the RM Finance database.


 

3.1   Importing Catalogue Codes

 

When importing Catalogue codes the user will be asked to enter a Default Supplier. The specified supplier must exist in Income Sources/Suppliers Account Records. If the record exists the import will proceed as normal.

 

 

 

3.2      Purchase Orders

In Purchase Orders once a Supplier has been selected the system will run a check to determine whether any catalogue codes exist against that Supplier.

 

If the Catalogue codes do exist against the supplier the Catalogue Codes search will look for records where the Catalogue Supplier matches the supplier selected on the Purchase Order.

 

Typing in a catalogue number on the order detail line will prompt the system to search for a matching catalogue code attached to that Supplier. If none are found the ‘Code Not Found’ popup window will appear

 

 

 

If a new code is required this can be added by clicking on New Code as normal, alternatively the code filter will allow searching for codes against the supplier selected on the Purchase Order.

 

 

 

If Catalogue Codes do exist against a supplier then the supplier check box will be ticked, the supplier entry field will be visible and enabled and it will be pre-populated with the Purchase Order supplier code.

 

If Catalogue Codes do not exist against a supplier the check box will be unticked

And the supplier field will be hidden from view.

 

In either case the check box may subsequently be ticked or unticked allowing the supplier record to be searched upon or not.

 

If the supplier check box is ticked and the supplier field is empty, then the search will find only catalogue codes where a supplier has not been specified.

 

Having run the search the list of catalogue codes will contain an additional column containing the supplier code[tks2].

 

 

 

It will be possible to select a catalogue code which is assigned a supplier that has not been selected on the purchase order header, or to select a catalogue code without a supplier attached when the Purchase Order supplier has its own Catalogue records.

 

This allows the supplier to be subsequently changed within the order header without requiring the order lines to be altered

 

The user can enter their order lines and then return to the purchase order header and change the supplier. The order lines will remain unchanged.

 

It will not be possible to attach a Supplier to

 

3.3   Tools[tks3]

3.3.1  Bulk Delete Catalogue Codes

A utility is available to bulk delete existing Catalogue Codes. The facility to do this is reached by using the Gateway functionality.

 

Go to File>Gateway

 

 

Enter the code CATDELETE, the following screen will appear.

 

 

Enter the relevant Supplier and click on Delete. It is essential to take a back-up prior to running this utility.

3.3.2  Supplier Code Change

A utility is available to change the existing Supplier Code on multiple catalogue records.

A new Gateway is provided which will allow all the catalogue records allocated to a certain supplier to be changed to a different supplier.

 

Go to File>Gateway

 

 

 

Enter the code CATUPDATE, the following screen will appear.

 

 

 

Enter the ‘Supplier From’ and the ‘Supplier To’ and click on update. It is essential that a Backup is taken prior to performing this routine.

 

If a new Catalogue code/Supplier code is already being used by a Catalogue record the record will be skipped and a warning message displayed at the end[tks4].


 

4      BACS[tks5] Functionality

4.1   Switching on BACS

An option entitled ‘BACS’ will appear on the RM Finance top horizontal menu bar.

 

Initially this option will be disabled and greyed out.

 

In order to active the BACS functionality a password needs to be entered via the file gateway.

 

Go to the File menu and select the Gateway option.

 

 

 

Type in the password ‘BACSACCESS’ and press <Enter>.

 

 

 

The Security Check screen should now be displayed, and a continuation code must be entered.

 

You will need to contact your support team who will provide you with a continuation code.

 

Note: In the event of the support team being fully engaged, you may wish to leave a message with them requesting they contact yourself regarding providing a continuation code, in which case you can click <Cancel> on this screen, returning when the support team call you back.

 

Having acquired a continuation code, enter this code and then click on the <OK> button.

 

If successful the following message will appear.

 

 

 

Click <OK>.

 

The following message will now appear.

 

 

 

Click <OK>.

 

BACS will now be enabled, and the BACS button on the top menu bar will now be enabled.

 

Clicking on the BACS button will open a menu bar down the left hand side on the screen.

 


4.2   Setup Options

4.2.1  User Access

 

New user access options are available for the new BACS functionality.

 

Go to System Manager > Users and Passwords > Access Levels

 

 

 

A new button entitled ‘BACS Access Levels’ will be present.

 

Clicking on this button will open the following popup screen.

 

 

 

By default the system administrator will be given full access to all the options, whilst other users will be given no access rights, and will therefore need to be set-up as required.

 

4.2.2  System Options

Go to System Manager > Options > Transactions Tab > Payments Printing Option.

 

When BACS is enabled the ‘Cheques’ option will be renamed ‘Cheques/BACS’.

 

When BACS is enabled (see earlier section ‘Switching on BACS’) the Payments Printing option will automatically be set to ‘On’ with ‘Cheques/BACS’ selected. BACS is only available with these settings.

 

Should the user click on the ‘Payment Authorisation’ option then the following No/Yes message will appear

 

Similarly clicking on the Payment Printing ‘Off’ button will produce the No/Yes message

 

Clicking ‘No’ in each case will reset the button back to ‘On’ with ‘Cheques/BACS’ selected.

 

If the user clicks ‘Yes’ on either of the messages, and then subsequently saves the changes (by clicking on the OK button) BACS will be turned off. The BACS menu option will be greyed out and disabled, all other BACS functionality will also disappear.

 

In order to re-enable BACS to user then need to back through the gateway option, (see earlier section ‘Switching on BACS’).

4.2.3  School Details BACS Settings

Go to System Manager > Organisation Details.

 

A new button will appear on Controls button bar entitled ‘BACS Settings’.

 

Clicking on this button will open the ‘BACS Settings’ popup window.

 

As part of the reorganisation process up to version 8.20 this button will be ticked.

 

If a supplier record is marked for both cheque payments and BACS, and “Make BACS the preferred payment method” is ticked, when that supplier is selected ‘BACS Payment’ will be selected as the default payment method, otherwise ‘Create Cheque’ will be selected.

 

Click OK to close the popup and return to the main Organisation Details screen

 

Note: In order to save BACS settings details you must also click on the <OK> button on the main (Organisation Details) screen, exactly the same as updating the ‘LEA Details’ screen.

 


4.2.4  Bank Details

Go to System Manager > Bank Details.

 

One bank account can be used for BACS payments, and this will need some extra values added.

 

Select the bank which is to be the BACS account, and click on the edit button.

 

Tick on the new ‘To be used for BACS Payment’ check box.

 

If another bank account is already designated as the BACS bank then the following OK error message will appear.

 

Upon clicking on the OK button the check box will be unchecked.

 

If no other bank account has been designated as the BACS bank account then upon checking the ‘To be used for BACS Payments’ button two new fields will APPEAR.

 

-          BACS Export Folder Location

-          Transfer Format

 

Both these fields must contain valid values for BACS to work.

 

Within the ‘BACS Export Folder Location’ field the folder location for the BACS export file should be entered. For schools using Windows 7 the location must be accessible by every user, not just the System Administrator. The ideal location would be the folder where the RM Finance data file is held.

 

The transfer format fields will contain a list of available Bank transfer formats. These are Lloyds, HSBC, RBS, Barclays Nat West, Yorkshire Bank and the Co-operative Bank

Bank details are saved by clicking on the ‘OK’ button’.

 

RM Finance will create the BACS export folder location automatically if it doesn’t already exist, if so requested. The following message will appear.

 

The value entered must be legitimate for a folder location, and the location needs to be free from any user access restrictions.

 

If the system is unable to create the folder then the following message will appear.

 

4.2.5  Supplier Record

Go to Records > Income Sources / Suppliers

 

When BACS is enabled a second tab entitled ‘BACS’ will be added onto the Suppliers record.

 

The payment method check boxes determine whether the supplier can be used for either cheques (as per existing functionality) or for BACs (new functionality). Neither, either or both maybe selected.

 

When it comes to entering an expenditure transaction for a particular supplier, only those payment methods selected for that supplier will be available.

 

If the ‘BACS’ payment method is checked, then a ‘Bank Account Name’, ‘Sort Code’ and ‘Account Code’ must all be entered. It will not be possible to save the record until these fields have been entered.

 

If the user has also clicked on the ‘Email’ Remittance method then a valid email address for the supplier must also be entered.

 

Setting the Remittance Method to ‘Print’ will mean that a printed remittance will be created for any BACS transaction when the BACS transfer file is created (see later).

 

Setting the Remittance Method to ‘Email’ will mean that a remittance advice will be created and sent to a file for any BACS transactions when the BACS transfer file is created (see later). This remittance file can then be included within an email and sent to the supplier.

 

4.2.6  Alternative Payees

Go to Records > Alternative Payees

 

When BACS is enabled a second tab entitled ‘BACS’ will be added to the Alternative Payee record.

 

The functionality here is much the same as occurs on the supplier record (see previous section)

 

The payment method check boxes determine whether the alternative payee can be used for either cheques (as per existing functionality) or for BACS (new functionality). Neither, either or both maybe selected.

 

When it comes to entering an expenditure transaction and the supplier alternative payee is selected, only those payment methods selected for that alternative payee will be available.

 

If the ‘BACS’ payment method is checked, then a ‘Bank Account Name’, ‘Sort Code’ and ‘Account Code’ must all be entered. It will not be possible to save the record until these fields have been entered.

 

If the user has also clicked on the ‘Email’ Remittance method then a valid email address for the alternative payee must also be entered.

 

Setting the Remittance Method to ‘Print’ will mean that a printed remittance advice will be created for any BACS transaction when the BACS transfer file is created (see later).

 

Setting the Remittance Method to ‘Email’ will mean that a remittance advice will be created and sent to a file for any BACS transactions when the BACS transfer file is created (see later). This remittance file can then be included within an email and sent to the supplier

4.2.7  Email Folder Location

Go to BACS > Email Folder Location

 

This option is to specify the folder location for remittance advices which are to be sent onto suppliers.

 

Note: It is important that the user has full read/write access rights to the specified folder location; otherwise this will compromise the BACS functionality. For schools using Windows 7 the location must be accessible by every user, not just the System Administrator. The ideal location would be the folder where the RM Finance data file is held.

 

RM Finance will offer to create the email folder location automatically if it doesn’t already exist.

The following message will appear.

 

The value entered must be legitimate for a folder location, and the location needs to be free from user access restrictions.

 

If the system is unable to create either folder then an error message will appear, and this could indicate that you have insufficient read/write access rights for creating folders. In such circumstances you will need to ensure read/write access rights are set-up.

 

4.3   BACS Transaction Entry

4.3.1  Overview

The Ability to post BACS transactions has been added to the following transaction options

 

-          Expenditure (single and multi line)

-          Credit Notes (single and multi line)

-          Purchase order payments (normal and express)

-          Expenditure Reversal

 

For RM Finance users not using BACS, the transaction functionality will be unaffected.

 

4.3.2  BACS Expenditure and Credit Note posting

Go to Transactions > Expenditure or Transactions > Credit Notes

 

The BACS functionality has been added to all the expenditure/credit notes (single and multi line) options in a consistent manner.

 

When BACS is enabled the ‘Create Cheque’ tick box will be replaced with a dropdown (payment method) list containing all the valid payment methods available for the selected supplier or alternative payee.

 

A line in the dropdown list must always be selected. The value ‘None’ (i.e. no payment method) will always be present in the list.

 

Whenever a supplier (or alternative payee) is selected the payment method list will be rebuilt so as to only include the payment methods selected for that supplier or alternative payee (see previous sections).

 

The system will also automatically pre-select to most appropriate payment method available.

 

So if a supplier or alternative payee has only been setup for cheque payments then the ‘Create Cheque’ option will be selected by default.

 

Likewise the ‘BACS Payment’ option will be selected if the supplier or alternative payee has only been setup for BACS.

 

If a supplier or alternative payee is setup for both cheque payments and BACS, then the system will refer back to the Organisation Details BACS settings option ‘Make BACS the preferred payment method’ in order to determine which payment option should be pre-selected.

 

Since there is only one BACS bank, if a BACS transaction has been created when the fund selection window appears upon saving the transaction, it will only contain the BACS bank which will be preselected.

 

Note: It will not be possible to create a BACS transaction should no bank be specified as the BACS bank. The following message will appear when attempting to save the transaction

 

4.3.3  Purchase Orders

 

Go to Transactions > New Order, Transactions > Express Order and Transactions > Amend/Process.

 

The initial entry of purchase orders will be unaffected by the new BACS functionality.

 

Only when the order comes to be paid does the new BACS functionality come into play.

 

When an invoice is received for an order go to Transaction > Amend Process, select the order as normal (having then received part or all of it)

 

 

 

Click on the Pay button.

The first Payments screen remains unchanged.

 

 

 

Enter an amount to pay as usual, and click on the Pay button, to open the payment detail screen

 

 

 

As in the expenditure screens when BACS is enabled the ‘Create Cheque’ check box is replaced with a drop down (payment method) list containing available payment methods for the selected supplier or alternative payee if one has been specified.

 

This list works in much the same manner as has already been described in the previous section.

 

One difference is that since the bank account has already been specified, if that bank is not the designated BACS bank then the ‘BACS Payment’ option will not appear in the list regardless of whether that payment method is available to the supplier and alternative payee.

 

Note: The specified bank account can be amended on the main ‘Amend / Process Purchase Order’ screen if required.

 

Having selected the payment method the order can then be paid.

 

If ‘Create Cheque’ was selected then a cheque record will be created (see Transactions > Payments > Print Payments), exactly as before.

 

Whilst if ‘BACS Payment’ was chosen a BACS record will be created (see BACS > Create BACS Export File). This functionality will be described subsequently.

4.3.4  Expenditure Reversals

 

Go to Transactions > Adjustments and corrections > Expenditure > Reversal

 

The reversal and reissue of a transaction with associated BACS record is handled in pretty much the same manner as for a transaction with an associated cheque.

 

Reversing a transaction with an associated uncompleted BACS record, the following message will appear.

 

 

 

Clicking ‘Yes’, the functionality will work as normal. The associated BACS record will be marked as allocated, and no longer appear for exporting (see following section).

 

Reversing a transaction with an associated completed BACS record (i.e. where the value has been uploaded to the bank via BACS), the following message will appear.

 

 

Upon clicking ‘Yes’ the following message will appear

 

 

 

Just like reversing transactions with associated printed cheques, reissuing will not only reverse the first transaction, but re-issue the transaction accompanied by a new BACS record.

 

4.3.5  Create BACS Export File

 

This option is not dissimilar to the cheque ‘Print Payments’ functionality. All outstanding BACS transactions are displayed and the user can choose lines form this list and create a BACS export file, which can then be uploaded to the bank.

 

Go to BACS > Create BACS Export File

 

 

 

An anticipated payment date must first be entered.

 

The date will be blank by default.

 

This date cannot be in the past.

 

Click <Cancel> to quit.

 

Once a valid date has been entered click on the <OK> button, the main ‘Create BACS Export File’ screen will then open.

 

 

 

All outstanding BACS transactions will appear in this list, sorted in supplier / alternative payee order.

 

Just like the ‘Print Payments’ functionality individual lines can be selected, or by clicking on the red arrow all lines will be selected.

 

Clicking on the ‘Print All’ button a report of all lines in the list will be created, for example.

 

 

If the ‘Print Selected’ button is pressed, this will produce a similar report but only including selected lines.

 

In order to create a BACS export file one or more lines must a selected.

 

Create Export

 

Having selected one or more lines and then clicking on the ‘Create Export’ button, providing previous set-up requirements have been completed (see setup options), the following message will appear.

 

 

 

If for some reason a BACS bank had not been specified, or no bank transfer format has been specified, or the required export folders have not been created then the BACS export will not be able to proceed, a suitable error message will appear instead.

 

If everything is correctly setup, clicking ‘OK’ to the above message the following will occur.

 

A printed remittance will be created for all lines where the remittance method is marked as ‘Print’, for example;

 

 

 

A file version of the remittance will be created for all lines where the remittance method is marked as ‘Email’.

 

For example if all the lines appearing on our example screen above were included, and the email folder location (see Email Folder Location section) was set to ‘c:\email’ then the following files will be created.

 

 

 

The two files starting with the text ‘Remittance’ are the remittances for the two suppliers requiring an email remittance. The file name includes the date, time, supplier/alternative payee code and the BACS number.

 

The third file “SUMMARY_4 MAR 2011_09-42.TXT contains a list (csv) of all the Remittance files which have been created, including the supplier email address.

 

For example:

 

c:\email\Remittance_4 MAR 2011_09-42_A&MALT_7.TXT,ddd@eeee>

c:\email\Remittance_4 MAR 2011_09-42_SUPTEST_9.TXT,

This email address is being protected from spambots. You need JavaScript enabled to view it.

 

The user can then send each remittance file in an email to the supplier.

 

Note: It is advisable once these remittances have been emailed for the email files to be moved into an archive type folder. Otherwise they might accidentally be emailed again.

 

And finally the BACS export file should be generated.

 

If the BACS folder location has been set to ‘c:\bacs’ (see Setup options, Bank Details section) then the BACS file will have been created within this location.

 

 

For Example

 

 

 

Note: this file contains the word ‘BACS’ followed by the date and time. It is also a comma separated file (csv).

 

And viewing the file contents in a spreadsheet

 

 

 

Note: Software supplied by the bank will then be responsible for uploading this file up to the banks system.

 

RM Finance will then display the following message

 

 

 

If the user is satisfied all the correct files and have been created and remittance printed correctly then they should click ‘Yes’, otherwise ‘No’ should be pressed.

 

Clicking ‘Yes’ all the selected BACS records will now be marked as completed and will no longer appear in the list. An internally generated BACS number will be allocated against each completed BACS record. This is similar to cheque numbers except this number series will start from 1, and cannot be manually altered. The BACS number is also written back to the originating expenditure transactions.

 

So viewing an example expenditure transaction in the Enquiries screen, the Reference field contains the BACS number, which is prefixed with the letters ‘BACS’

 

Note: Also observe the BACS Type field (bottom left) which displays the payment method associated with the transaction.

 

If the user clicked ‘No’ to the ‘Have the BACS files been created OK?’ message then the following message will appear.

 

At this stage the BACS file, plus any email remittance files will have been created. But if the export is now being cancelled these files must also be removed, otherwise potentially the BACS file could be incorrectly sent to the bank.

 

Click ‘No’ and you will be returned to the ‘Have the BACS files been created OK?’ message.

 

Clicking ‘Yes’ will then delete the newly created BACS file and any email remittance files.

The user is strongly advised to check that these files no longer exist. Focus will now be returned to the ‘Create BACS Export File’ screen, and any adjustments, etc can then be made to the selection.

4.4   BACS Reports

4.4.1  Payment Pending Report

Go to BACS > Payments Pending Report

 

The payments printing report will print all pending BACS Payments within a specified supplier and/or date range. The report is sorted and subtotalled by supplier and alternative payee.

 

4.4.2  Re-Print Remittances

 

Go to BACS > Re-Print Remittances

 

The report allows you to re-print a remittance, for a BACS payment

 

This option is very similar to the existing cheque payments re-print payment option.


4.4.3  Remittance Report

Go to BACS > Remittance Report

 

The BACS Remittance report displays details of all BACS payments which have previously been generated, based upon the search criteria which has been entered.

 

The report prints in BACS number order.

 

Example Remittance report

 


4.5   Report Maintenance Log

Go to Transactions > reports > Audit Reports > Record Maintenance Log

 

When BACS is enabled this report option will be available.

 

This report shows what records have been created, deleted, plus details of any fields which have been edited. The report prints in date and time order.

 

The report can be printed for a specific date range

 

It can be printed for a specific user or all users (i.e.: ‘N/S’ not specified).

 

It can be printed for a specific record type (Income source/suppliers, users or alternative payees), or for all three records types (i.e.: ‘N/S’ not specified).


5      Other Functionality

5.1      Purchase Orders

A warning now appears if the Bank will be overdrawn when posting an invoice for payment

 

 

 

5.2      Records – Drill down on Income Sources/Suppliers

The drill down from Records – Income Sources/Suppliers on both Turnover Year to Date and Turnover Period to Date shows both the invoice number and cheque number

 

 

 

 

5.3      Records – Search on Income Sources/Suppliers

Additional Functionality has been added to the search function within Records – Income Sources/Suppliers. It is now possible to search for a particular Supplier using their post code

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6      PR Tracker Items

6.1   Supplier Record

It is no longer possible to create a Supplier with no name via Purchase Ordering either New Order or Express Order.

6.2   Printed BACS Remittance

 

A new remittance type has been added to BACS functionality. This BACS Remittance has been adjusted to fit a window envelope. To select the remittance go to BACS>Document Setup and select Revised

 

 

 

6.3   Value Box on Purchase Orders

Within the Amend/Process Payment screen the value field have been adjusted to ensure that values are no longer truncated.

 

 


 

7      Installing RM Finance on Microsoft Windows 7 Computer

 

 

32-bit & 64-bit Microsoft®   Windows® 7 installations

 

There are two varieties of   windows 7 operating system, 32-bit and 64-bit.

RM Finance will work on   either operating system, however it is recommended where possible that the   32-bit variation be used.

 

Servers

 

Many installations have multiple   client computers onto which RM Finance is installed, all accessing a   central data file held on a server. Within a typical installation,   local computers may be running Windows 7, while the server   might be running another operating system.
  As general good practice, it is recommended that the server's operating   system be fully patched and up-to-date. If the server is running Windows   Server® 2003, this must be fully patched and running Service Pack 2 or   later.

 

Virtualisation

 

Windows 7 contains some   functionality termed Virtualisation which could result in software or data   files not being stored at the expected file locations. An application or data   file appearing to be stored at one file location is actually stored down   in another location, specific to the user.
  This can apply to any files running on a Windows 7 computer.
  It is advised that RM Finance and any data files are not subject to   virtualisation.
  RM Finance should be installed by a user with full system administrator   access and privileges and we would advise that it is installed in a folder   which is not under Program Files. Data files should be held in locations   where virtualisation will not apply, i.e. areas with full access.

 

Safe backup

 

On some installations 'Safe   backup' was found not to work correctly.
  Note: This was actually an item which occasionally occurred on an   earlier system, so not strictly a Windows 7 issue.
  An error along the following lines might occur:
  "An Error occurred component MSCOMCTL.OCX or one of its dependencies not   correctly registered a file is missing or invalid."
  Instead of file MSCOMCTL.OCX, it may refer to file COMDLG32.OCX or   XCeedZip.dll.
  If the message is different, then you should refer to your local support team   for further guidance.
  In order for Safe backup to work, the file named within the error message   will need to be registered.
 
  Follow the steps below to register a file:

      
  1. Log        on to the Windows 7 computer.
  2.   
  3. Click        Start, All Programs, Accessories, right-click the Command Prompt and        choose 'Run as Administrator' from the context menu.
  4.   
  5. In        the Command Prompt window, follow the steps below:
  6.   
         
    • For 32-bit Window 7 installations, navigate         to c:\windows\system32 as follows:
    •    
            
      1. In the Command Prompt type c: and press          Enter.
      2.     
      3. Type cd c:\windows\system32 and press          Enter.
      4.     
      5. The Command Prompt  should now show          c:\windows\system32
      6.    
         
    • For 64-bit Window 7 installations, navigate to         c:\windows\syswow64 as follows:
    •    
            
      1. In the Command Prompt type c: and press Enter.         
      2.     
      3. Type cd c:\windows\syswow64 and press          Enter.
      4.     
      5. The Command Prompt should now show          c:\windows\syswow64.
      6.    
        

Note:   The file should be located within this folder and will need to be registered.  

      
  1. Type        Regsvr32 followed by the file name.
           If the file in question is MSCOMCTL.OCX, type Regsvr32 MSCOMCTL.OCX,        then press the Enter key. If you receive an error then please see        Alternative Method section.
  2.   
  3. Steps        1-3 may need to be repeated for the other files, but try running Safe        backup again first. If another error occurs for a different file name,        repeat the same steps for that file.

 

Alternative method

 

In some cases, it is not   possible to re-register DLLs and OCX files unless you are actually logged on   as the administrator user. A systemadmin user does not give you enough   access. To resolve this, follow the procedure below:

      
  1. Click        Start>All Programs>Accessories and select Notepad.
  2.   
  3. Copy        and paste the following to the Notepad file:

c:\windows\system32\regsvr32 c:\windows\system32\mscomctl.ocx
  c:\windows\system32\regsvr32 c:\windows\system32\comdlg32.ocx   c:\windows\system32\regsvr32 c:\windows\system32\xceedzip.dll

      
  1. Save        the file onto My Documents or desktop with the name REG.BAT. 
           Note: It is important that the name does not appear as        REG.BAT.TXT.
  2.   
  3. The        file should then appear on your desktop or My Documents with an icon of        a small cog. If you get a TXT icon, then this is incorrectly named.
  4.   
  5. Right-click        on the REG.BAT file and select 'Run as Administrator'. Enter your        administrator password as prompted and then click OK to the three        confirmation messages.

If you are unable to   complete these steps or you receive error messages, please contact SMS   support on This email address is being protected from spambots. You need JavaScript enabled to view it..

8        Crystal reports

 

 

 


 [tks1]I was surprised there no screenshot of the Catalogue screen. I know it’s appearance hasn’t changed but it think if we provided a screenshot and an explanation saying that the Catalogue code was no longer unique, and stressed the role of the supplier field, this would add clarity to the subsequent sections.

 [tks2]Screenshot would be nice

 [tks3]I’d probably put the Gateway options last and move forward the Purchase Order functionality. The Core bit is the purchase orders, the gateways are additional tools which the user might find useful

 [tks4]Might also want to advise on the usefulness of taking a backup prior to running.

 [tks5]New Page maybe

Contents

1.1   Overview... 3

1.2   Which modules are included in this release?.. 4

2.1   Existing Stand-alone CFR User.. 5

2.2   Windows 7 Virtualisation.. 6

2.3   New Stand-alone CFR User.. 7

2.4   Verifying the installation.. 9


1      Introduction

1.1   Overview

There is just one main change for the 2012 / 2013 CFR return; this is the introduction of a new income field I18 “Additional Grant for Schools”.

I18 is now fully incorporated within the CFR functionality, including within entry screens, import maps, the return file, validations rules and reporting.

CFR codes guidance has also been updated for various CFR codes.

Otherwise the 2012 / 2013 CFR return remains unchanged from the previous year.

The basic CFR application (1.90.00) remains exactly the same as 2011 / 2012, incorporating the changes mentioned above.

The Release Notes describe the changes included within this version of the software, and also include installation instructions explaining how to upgrade existing versions of the CFR Assistant to version 1.90.00. Please ensure that you read this entire Release Note document before installing the new version of the CFR Assistant.


1.2   Which modules are included in this release?

Module

Version

CFR

1.90.00

Core

6.84.70

Coredata

6.84.60

NOTE that once a datafile has been upgraded to version 1.90.00 of CFR, it cannot be used in an earlier version.


2      Installation Instructions

2.1   Existing Stand-alone CFR User

IMPORTANT NOTE – As with all upgrades, please ensure you have taken a back-up of your datafile and associated DEF file prior to upgrading to the new version of CFR Assistant.

Existing users of the CFR stand-alone product can install the update in one of two ways:

Either – use the self-extractor provided to update your CFR module, as described in the following instructions.

Or – uninstall the previous version of CFR from the Windows Control Panel, and then install the complete CFR installer for new users (described in section 2.2 below).

To use the self-extractor:

  1. Start your computer, and insert the CFR Assistant CD-ROM into      your CD-ROM drive.
        
        
  2. Run      the StandaloneUserCFR1_90_00.exe      from the Standalone Users\Existing      Users folder on the CD.
  1. You      will be prompted for a location to unzip the files to – this should be      your main CFR folder, which defaults to C:\Program Files\RM Management Solutions\RM CFR Assistant.
  1. Click      on the Unzip button to extract      the file. You will find that the new CFR module (CFR.lbr) is placed in your C:\Program Files\RM Management      Solutions\RM CFR Assistant\Bin folder. Updated CFR Guidance pages will      also be copied into the C:\Program Files\RM Management Solutions\RM CFR      Assistant\CFR folder and updated an updated lea list into the C:\Program      Files\RM Management Solutions\RM CFR Assistant\CBDS\PARAMS folder.
  1. Start      CFR Assistant in the usual way. You can check the System Information      screen (Help > System Information) to ensure the modules have updated      correctly.
  1.  

2.2     Windows 7 Virtualisation

Windows 7 contains some functionality termed   Virtualisation which could result in software or data files not being stored   at the expected file locations. An application or data file appearing to   be stored at one file location is actually stored down in another location,   specific to the user. This can apply   to any files running on a Windows 7 computer.


  Note: The procedure below assumes that CFR and the data file being used are   currently in the folder C:\Program Files (x86)\RM Management Solutions\RM CFR   Assistant\BIN\ which is the standard installation folder. If you have   installed it in a different folder under C:\Program Files (x86) then you will   need to alter the steps appropriately.

 

 


2.3   New Stand-alone CFR User

  1. Start your computer, and insert the CFR Assistant CD-ROM into      your CD-ROM drive.
        
        
  2. Run      the Setup.exe installation file      from the Standalone Users\New Users      folder on the CD.
  1.                                                                                                                                                             
         After a few seconds, the Windows Installer window shown in Figure 1      will be shown.

Figure 1 – RM CFR Assistant Installer

  1. Clicking      on the Next button will present      you with an End User License Agreement. You must accept the terms of this      agreement, and then click Next      to proceed through the installation wizard.
  1. You      should choose to install a Complete      installation of the program when asked.
  1. After      installing the CFR Assistant, you can run the software by clicking on the Start button and selecting CFR Assistant from the RM Management Solutions folder on      the menu.

   
Figure 2 – Start Menu

The first time you start the CFR Assistant software you will have to create a new datafile before you can log into the software. This datafile contains all the information that you enter into the CFR Assistant. Please note that this datafile is for the CFR Assistant Software – you should not connect the stand-alone variant of the CFR Assistant to an existing Integris or RM Finance datafile.

   
When you activate the CFR Assistant after installing it for the first time, the system displays the Datafile window.

Figure 3 – Datafile Window

To create the new datafile, click on the Create a new datafile button. You can specify the name of your datafile, and then click on the OK button to create the datafile. Datafiles are not allowed to contain certain characters or have certain names. You will be warned if you choose an invalid datafile name.

Two files will be created – one will be called datafile name.df1, and the other is datafile name.def. Both of these files make up the data for the CFR Assistant, and hence the two files should always be kept together. Whenever you move, copy or take a backup of the datafile, you must include the .def file in your movement, copy or backup process.

If you wish to have many users accessing the same datafile, you may choose to place your datafile in a shared folder on your computer, or on a server that more than one person can access. Once the datafile has been created, other users should not create a new datafile, but should instead choose the Open an existing datafile button from the window above, and choose the datafile that you have just created.

2.4   Verifying the installation

Once the installation is complete you should verify that the modules have installed correctly on your system. To perform this check:

  1. Open CFR after performing      your upgrade/installation.
  2.                  From the Help menu,      select System Information.

The installation has been successful if the CFR module is showing version 1.90.00 (14/03/13) as highlighted in the image above.

Subcategories


TOP