Important Information About "Spectre" and "Meltdown" Processor Security Holes

As you may already know from media reports, two security vulnerabilities known as "Spectre" and "Meltdown" have been uncovered. These security vulnerabilities can lead to various attack scenarios on modern computer processors.

Due to the gravity of this issue, our hardware suppliers have already begun to migrate our servers to the latest product version. Only with this version is it possible to minimize the risk and apply the required patches for the virtualization layer. In order to perform the migration, the servers must be shut down and will not be available for a certain amount of time.

Due to the urgency, our suppliers are unfortunately unable to give an exact timeframe for the necessary security updates. They will process the migration as quickly as possible. Additionally, our suppliers are installing all the necessary security patches. Since several patches for firmware, virtualization software and operating system may be required, it is unfortunately not possible to synchronize the installations. Therefore, it is quite possible that our servers will be affected by several short downtimes. When possible, the patches will be installed overnight.

We apologise for any inconvenience this may cause and we ask for your understanding that we are operating for your own safety.

Help & Support

help support flat200

Our dedicated training facility is conveniently located in the main building at County Hall.

Read More

Office 365

office365 flat200

You might just know Office 365 as an e-mail system. But, believe me, it is so much more than that.

Read More

Special Offers

special offer flat 200

We like to strike a good deal with our suppliers and pass the savings on to schools. Visit our special offers pages for the latest deals.

Read More

Website Services

websites flat200

Buy a new WordPress and Joomla CMS website or view our additonal web services

Read More


TOP